BACKTRACE

(condense)

Back to Posts List

GET

Ruby On Rails and Oracle: New version for oracle_enchanced_adapter

A new version for the oracle_enhanced_adapter is now out, which is exciting for those of use who chose to work with Oracle.
Use can use the Oracle enhanced adapter:

  • on MRI 1.8.6 with ruby-oci8 1.0.x library or gem
  • on JRuby (so far tested with 1.1.6) with JDBC Oracle driver
  • on Ruby/YARV 1.9.1 with ruby-oci8 2.0 library or gem

And, which is the coolest, Oracle enhanced adapter passes 100% ActiveRecord unit tests!

install the new adapter by:


$ sudo gem install activerecord-oracle_enahnced-adapter

note that some of the SQL compatible with Mysql and is used by rails, is not compatible with Oracle, so run your tests again.

POST

blog comments powered by Disqus

I Don't have cookies.

ELAD ENV

Variable Value
LINKEDIN
TWITTER
FACEBOOK
GITHUB
WWR
IRC
{ 'irc.freenode.net' => [ '#rubyonrails', '#railsbridge', '#ruby', '#mootools' ]}
SKYPE
eladmeidar

You're seeing this error because I think it is funny.